use strict;
my $str = '1. this isa (test)
2. tis is a {{test}}
3. thisis a {{instance.test}}
4. thisis a {{instance.something}}
5. this is a {{window.location.hostname}} {{window.location.protocol}} ';
my $regex = qr/\{\{window\.location\.(.+?)\}\}/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}