// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\{\{window\.location\.(.+?)\}\}").unwrap();
let string = "1. this isa (test)
2. tis is a {{test}}
3. thisis a {{instance.test}}
4. thisis a {{instance.something}}
5. this is a {{window.location.hostname}} {{window.location.protocol}} ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}