# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]"
test_str = ("1. [ \"Italy\" ] * 5 - [ \"France\",\"Paris\" ] + 2\n\n"
"2. 3*12 * [\"Country\"] + [\"City\".] * 2 + [\"\"]\n\n"
"3. [Madrid]\n\n"
"4. [\"Spain\"] * [\"Name \"Industry\"\"]\n\n"
"5. \"My issue\" / [\"Error] [\"some name\"]\"] * 3 + 4`\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.