re = /\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]/m
str = '1. [ "Italy" ] * 5 - [ "France","Paris" ] + 2
2. 3*12 * ["Country"] + ["City".] * 2 + [""]
3. [Madrid]
4. ["Spain"] * ["Name "Industry""]
5. "My issue" / ["Error] ["some name"]"] * 3 + 4`
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end