$re = '/((\d+(?:\.\d+)?).*\(Scored\))/ms';
$str = '2.10 Add nodev Option to Removable Media Partitions
45 FDFDF
(Scored)
Profile Description:Set nodev on removable media to prevent character and block special devices that are present , on the removable media from being treated as device files.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);