// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"001("[^"]*")*([^@]*)*@"#).unwrap();
let string = "001@001Semper exitialis \"fkjfk\"cum subsidia ductor notissimus subsidia et ductor cui@001Annonas et \"@\"et contumaciter conspectum@001Quo amicissimos ad uxoriae certamen pecuniae tamen =\"@\" dirimi conte\"klkj @\"ntione nullam.@001hsjh@";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}