$re = '/~\|~/';
$str = '1~|~Vijay~|~25~|~Pune';
$subst = "\n|\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;