#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\bhttps?\:[^ {}\[\]]+?\.jpg\b)"
Local $sString = "<option value="https://cdn.images.com/storage/The science/7456t5435435_d6186a5f10.png"" & @CRLF & _
" >" & @CRLF & _
" Flask" & @CRLF & _
" </option>" & @CRLF & _
" <option value="https://cdn.images.com/storage/The science/54645yt654_d6186a5f10.jpg"" & @CRLF & _
" >" & @CRLF & _
" Flask" & @CRLF & _
" </option>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")