import Foundation
let pattern = #"(\bhttps?\:[^ {}\[\]]+?\.jpg\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<option value="https://cdn.images.com/storage/The science/7456t5435435_d6186a5f10.png"
>
Flask
</option>
<option value="https://cdn.images.com/storage/The science/54645yt654_d6186a5f10.jpg"
>
Flask
</option>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)