re = /%%name%%/
str = 'Welcome, %%name%%!
Congratulations!'
subst = '\\$1ndy'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result