import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@(?<planet>[A-Z,a-z]+)(?:[^@\\-!:]+)?:(?<population>[\\d]+)(?:[^@\\-!:]+)?!(?<type>[A|D])!(?:[^@\\-!:]+)?->(?<soldiers>[\\d]+)";
final String string = "PQ@Alderaa1:30000!A!->20000\n"
+ "@Cantonica:3000!D!->4000NM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}