$re = '/^(([^;]+; )*(x1=y2;|c5=c6;) ?){2}/m';
$str = 'a3=b4; x1=y2; x1=y2; ...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);