const regex = /^[0\.\,]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0\\.\\,]*$', 'gm')
const str = `0.000,00
0.000.000.00
0
10
dafsd
0,3
1.0
0,00004
1.000
000000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}