#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\(\d{4}(?:[\sāā-]+(?:\d{4}|present))?\)"
Local $sString = "The Adventures of Sherlock Holmes (1891ā1892) (series), (1892) (novel), Arthur Conan Doyle" & @CRLF & _
"This is Agent (1857), the years were (1987-1868), which lasted from (1678- Present)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")