using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\d{4}(?:[\sāā-]+(?:\d{4}|present))?\)";
string input = @"The Adventures of Sherlock Holmes (1891ā1892) (series), (1892) (novel), Arthur Conan Doyle
This is Agent (1857), the years were (1987-1868), which lasted from (1678- Present)";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}