// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\(\d{4}(?:[\sāā-]+(?:\d{4}|present))?\)").unwrap();
let string = "The Adventures of Sherlock Holmes (1891ā1892) (series), (1892) (novel), Arthur Conan Doyle
This is Agent (1857), the years were (1987-1868), which lasted from (1678- Present)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}