import Foundation
let pattern = #"\(\d{4}(?:[\sāā-]+(?:\d{4}|present))?\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
The Adventures of Sherlock Holmes (1891ā1892) (series), (1892) (novel), Arthur Conan Doyle
This is Agent (1857), the years were (1987-1868), which lasted from (1678- Present)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)