$re = '/\.select \h* ( \( (?> [^()]++ | (?1) )* \) )/x';
$str = '.select( foo(bar()) ) abcd
.select( foo() )
.select()
.asdf( foo(bar()) )
.asdf( foo() )
.asdf()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);