const regex = /^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(import|export).*({[^{}]*\\n})?.*\'(?<file>.*)\'.*$', 'gm')
const str = `import { contextBuilder } from '@graphql/context';
import resolvers from '@graphql/resolvers';
import {
getDeviceFromHeaders,
getUserFromHeaders,
getRealIp,
} from '@utils/headers';
export * from './ChallengesAPI';
export * from './HealthDataCollectorAPI';
export * from './AlfredAPI';
import { formatRoundedNumber } from '@utils/number';
import type {
EligibilityType,
OfferPlan,
OfferPlanQuote,
PacificOffer,
} from 'generated/graphql';
import { formatRoundedNumber } from '@utils/number';
import {
formatScaledPriceByCountry,
formatScaledPriceCurrency,
} from '@graphql/domain/plan/price';
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}