# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$"
test_str = ("import { contextBuilder } from '@graphql/context';\n"
"import resolvers from '@graphql/resolvers';\n"
"import {\n"
" getDeviceFromHeaders,\n"
" getUserFromHeaders,\n"
" getRealIp,\n"
"} from '@utils/headers';\n"
"export * from './ChallengesAPI';\n"
"export * from './HealthDataCollectorAPI';\n"
"export * from './AlfredAPI';\n"
"import { formatRoundedNumber } from '@utils/number';\n"
"import type {\n"
" EligibilityType,\n"
" OfferPlan,\n"
" OfferPlanQuote,\n"
" PacificOffer,\n"
"} from 'generated/graphql';\n"
"import { formatRoundedNumber } from '@utils/number';\n"
"import {\n"
" formatScaledPriceByCountry,\n"
" formatScaledPriceCurrency,\n"
"} from '@graphql/domain/plan/price';\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.