$re = '/^(eq|[gln]e|[bclg]t)\s*:\s*\d+(?:\.\d+)?(?:-\d+(?:\.\d+)?)?$/m';
$str = 'eq:4
ne:41
gt:41-67
lt^:45
lt:43a
eq:**+4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);