using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(house|car)(?: (?!(?:house|car)\b)\w+){1,10} (?!\1)(house|car)\b";
string input = @"car word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 house
house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 car
house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 word 11 car
car test car
house test house
house house house
car car car
this is a test house riding a new car
testing a car when testing a house test test test test test test test test test test test test house";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}