#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^NODE_([0-9]+)_.*_([0-9]+)"
Local $sString = "NODE_1_length_59711_cov_84.026979_g0_i0_1 12.8" & @CRLF & _
"NODE_1_length_59711_cov_84.026979_g0_i0_2 18.9" & @CRLF & _
"NODE_2_length_59711_cov_84.026979_g0_i0_1 14.3" & @CRLF & _
"NODE_2_length_59711_cov_84.026979_g0_i0_2 16.1" & @CRLF & _
"NODE_165433_length_59711_cov_84.026979_g0_i0_1 29"
Local $sSubst = "$1_$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)