use strict;
my $str = 'NODE_1_length_59711_cov_84.026979_g0_i0_1 12.8
NODE_1_length_59711_cov_84.026979_g0_i0_2 18.9
NODE_2_length_59711_cov_84.026979_g0_i0_1 14.3
NODE_2_length_59711_cov_84.026979_g0_i0_2 16.1
NODE_165433_length_59711_cov_84.026979_g0_i0_1 29';
my $regex = qr/^NODE_([0-9]+)_.*_([0-9]+)/mp;
my $subst = '$1_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";