$re = '/\d+(?!\d)(?! ?(?:red|green)).*(\bwarehouse\b)/m';
$str = '123 warehouse
123 token warehouse.
123token token abc123; etc. - warehouse
123abdc token abc green warehouse
But not these lines:
123red warehouse.
123 green token token etc warehouse. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);