\d{6}a digit, repeated exactly 6 times
.any character (except for line terminators)
\S{1,3}any non-whitespace character, repeated between 1 and 3 times
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string