#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:https?:\/\/)?(?:www\.)?youtu(?:be)?\.(?:com|be)(?:\/watch\/?\?v=|\/embed\/|\/shorts\/|\/)(\w+)"
Local $sString = "https://youtu.be/YOUTUBE_ID?123" & @CRLF & _
"https://www.youtube.com/embed/YOUTUBE_ID?123" & @CRLF & _
"https://www.youtube.com/watch?v=YOUTUBE_ID?asd" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/YOUTUBE_ID&123" & @CRLF & _
"https://www.youtube.com/embed/YOUTUBE_ID&123" & @CRLF & _
"https://www.youtube.com/watch?v=YOUTUBE_ID&asd" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/YOUTUBE_ID/123" & @CRLF & _
"https://www.youtube.com/embed/YOUTUBE_ID/123" & @CRLF & _
"https://www.youtube.com/watch?v=YOUTUBE_ID/asd" & @CRLF & _
"https://youtube.com/shorts/YOUTUBE_ID?feature=share" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")