import re
regex = re.compile(r"(?:https?:\/\/)?(?:www\.)?youtu(?:be)?\.(?:com|be)(?:\/watch\/?\?v=|\/embed\/|\/shorts\/|\/)(\w+)")
test_str = ("https://youtu.be/YOUTUBE_ID?123\n"
"https://www.youtube.com/embed/YOUTUBE_ID?123\n"
"https://www.youtube.com/watch?v=YOUTUBE_ID?asd\n\n"
"https://youtu.be/YOUTUBE_ID&123\n"
"https://www.youtube.com/embed/YOUTUBE_ID&123\n"
"https://www.youtube.com/watch?v=YOUTUBE_ID&asd\n\n"
"https://youtu.be/YOUTUBE_ID/123\n"
"https://www.youtube.com/embed/YOUTUBE_ID/123\n"
"https://www.youtube.com/watch?v=YOUTUBE_ID/asd\n"
"https://youtube.com/shorts/YOUTUBE_ID?feature=share\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")