use strict;
my $str = '{
"foo": "bar",
"age": 23,
}';
my $regex = qr/(?<=")(.*?)(?=":)/mp;
my $subst = '<span style="color: red;">$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";