using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([1-9]|[12][0-9]|30|[0-9]{4})$";
string input = @"1
2
3
4
5
6
7
8
9
0
09
10
30
31
49
56
99
100
999
1000
0120
0001
9999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}