package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]|[12][0-9]|30|[0-9]{4})$`)
var str = `1
2
3
4
5
6
7
8
9
0
09
10
30
31
49
56
99
100
999
1000
0120
0001
9999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}