// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([1-9]|[12][0-9]|30|[0-9]{4})$").unwrap();
let string = "1
2
3
4
5
6
7
8
9
0
09
10
30
31
49
56
99
100
999
1000
0120
0001
9999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}