use strict;
my $str = 'python...is...fun...
python...is...fun
python...is...fun??';
my $regex = qr/\.*$/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";