re = /[0-9]+(\.[0-9]{2})?\|[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,[A-Z]{2},[A-Z]{2}[+*]?([0-9]+)?(\s+"Description")?/m
str = '62.00|LQ+2*2,FP,MD*3 "Description"
62|LQ+2*2,FP,MD*3 "Description"
62|LQ+2*2,FP,MD*3
62|LQ*2,FP,MD*3
62|LQ+8,FP,MD*3
62|LQ,FP,MD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end