// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[0-9]+(\.[0-9]{2})?\|[A-Z]{2}[+*]?([0-9]+)?[+*]?([0-9]+)?,[A-Z]{2},[A-Z]{2}[+*]?([0-9]+)?(\s+"Description")?"#).unwrap();
let string = "62.00|LQ+2*2,FP,MD*3 \"Description\"
62|LQ+2*2,FP,MD*3 \"Description\"
62|LQ+2*2,FP,MD*3
62|LQ*2,FP,MD*3
62|LQ+8,FP,MD*3
62|LQ,FP,MD";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}