#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\${(\s*((?<rewriter>[^(\s]+)\s*\(\s*(?<key>[^()?\s}]+)\s*\)\s*)|(\s*(?<key>[^()?\s}]+)\s*))(\?(?<fallback>[^}]*))*}"
Local $sString = "${func(key)?default}" & @CRLF & _
"${func(} should not match" & @CRLF & _
"${func(key} should not match" & @CRLF & _
"${key)} should not match" & @CRLF & _
"${key}" & @CRLF & _
"${key?}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")