using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bFlorida\b(?!.*\bFlorida\b).*";
string input = @"Arkansas; Hawaii; South Dakota; North Carolina
California;Florida; Washington State; New York; Florida; West Virginia; DC
Nevada; Texas; New Mexico; Georgia";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}