$re = '/https:\/\/site\.com\/([^\/]+\/){3}([^\/]+)\/[^.]+(.*)/m';
$str = 'https://site.com/content/images/45/1000x1000l80mc0/copy_kvadrokopter-lyzrc-l900-pro-orange-dron-z-4k-i-hd-kamerami-esc-fpv-gps-bk-motori-do-1200m-28-khvilin-50233095308044.webp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);