#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![/\w:]*:[:/])[/\w:]*$"
Local $sString = "" & @CRLF & _
"/" & @CRLF & _
":id" & @CRLF & _
"/:id" & @CRLF & _
"/:id/" & @CRLF & _
"person/:name/:id/:token_person2/image" & @CRLF & _
"person////" & @CRLF & _
"////" & @CRLF & _
":::id" & @CRLF & _
"person/:/name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")