using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![/\w:]*:[:/])[/\w:]*$";
string input = @"
/
:id
/:id
/:id/
person/:name/:id/:token_person2/image
person////
////
:::id
person/:/name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}