$re = '/^(?![/\w:]*:[:/])[/\w:]*$/m';
$str = '
/
:id
/:id
/:id/
person/:name/:id/:token_person2/image
person////
////
:::id
person/:/name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);