using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(10.0.0.[0-9]{1,3})(\/32)";
string input = @"10.0.0.1/32, 10.0.0.12/32, 10.0.0.123/32";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}