using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":[^[:alpha:]]*\K[[:alpha:]]+\b";
string input = @"Weekend Team: ~ Vincent Smith Operations
Weekend Team: ~ Jana'ya Smith Operations
Weekend Team: ~ h4cker Smith Operations
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}