re = /(?:\G(?!^)",|"groups":\s*\[)\s*"\K[^"]+/m
str = '{
"policyItems": [
{
"accesses": [
{
"type": "submit-app",
"isAllowed": true
}
],
"users": [],
"groups": [
"Application_Team_1",
"team2"
],
"conditions": [],
"delegateAdmin": false
}
]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end