// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"wanted\(.*{(.|\n)*}\n{2,}").unwrap();
let string = "function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}
wanted()
function wanted() {
const a = 555;
if (a === 1) {
while (true) {
break;
}
}
}
function someFunc() {
const a = 6;
if (a === 7) {
while (true) {
break;
}
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}