const regex = /[A-ZÑÁÉÍÓÚ\s]+/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-ZÑÁÉÍÓÚ\\s]+', 'gs')
const str = `JUAN MORENO
JULIÁN MARTINEZ
ÑANDO TORRES ORTULIZAN
GULIAN GÚRRAIN`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}