$re = '/(0|84|\+84)/m';
$str = '0123
8456
+8456
345
555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);