using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w]+)\s?=\s?([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))?([-+])*[Rr]amp\(FinalValue:([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))([\w]*),RampTime:([0-9]*\.[0-9]+|[0-9]+)([\w]*)\)";
string input = @"Rx_TrqMax_Rq = Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq =100+Ramp(FinalValue:100.50Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50+Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50-Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = Sin(Amplitude:100Nm,Frequency:10ms)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}