# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\w]+)\s?=\s?([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))?([-+])*[Rr]amp\(FinalValue:([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))([\w]*),RampTime:([0-9]*\.[0-9]+|[0-9]+)([\w]*)\)"
test_str = ("Rx_TrqMax_Rq = Ramp(FinalValue:100Nm,RampTime:10ms)\n"
"Rx_TrqMax_Rq =100+Ramp(FinalValue:100.50Nm,RampTime:10ms)\n"
"Rx_TrqMax_Rq = -100.50+Ramp(FinalValue:100Nm,RampTime:10ms)\n"
"Rx_TrqMax_Rq = -100.50-Ramp(FinalValue:100Nm,RampTime:10ms)\n"
"Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)\n"
"Rx_TrqMax_Rq = Sin(Amplitude:100Nm,Frequency:10ms)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.