import Foundation
let pattern = #"([\w]+)\s?=\s?([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))?([-+])*[Rr]amp\(FinalValue:([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))([\w]*),RampTime:([0-9]*\.[0-9]+|[0-9]+)([\w]*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Rx_TrqMax_Rq = Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq =100+Ramp(FinalValue:100.50Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50+Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50-Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = Sin(Amplitude:100Nm,Frequency:10ms)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)